2008 Sun T5120

Purchased in 2015 to experiment with alternate CPU architectures. Currently this machine hosts all of my public infrastructure.

Contents

Documentation
2015
2020
2021
2022

Documentation

The service manual.

Product Name: SPARC-Enterprise-T5120
Part/Serial Number: 602-4370-02 / BEL0927EM3
SysFW Version: Sun System Firmware 7.4.5 2012/12/11 23:47
ILOM Version: v3.0.12.4.y r77080

2015

Purchase

I purchased this Sun Sparc Enterprise T5120 in late 2014. It came from Utica NY for around $800. My previous Sun Fire V210 was a little too slow and this was it's upgrade.

Upgrade disks

I upgraded the two original magnetic drives with 2x500Gb Samsung 850 SSD's. It turns out SSD connectors and SAS connectors are interchangeable.

2020

OpenBSD 6.8

dmesg
console is /virtual-devices@100/console@1
Copyright (c) 1982, 1986, 1989, 1991, 1993
	The Regents of the University of California.  All rights reserved.
Copyright (c) 1995-2020 OpenBSD. All rights reserved.  https://www.OpenBSD.org

OpenBSD 6.8-stable (GENERIC.MP) #0: Sun Jan 17 19:40:46 PST 2021
    milz@1.0x30.net:/sys/arch/sparc64/compile/GENERIC.MP
real mem = 17179869184 (16384MB)
avail mem = 16859095040 (16078MB)
random: good seed from bootblocks
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root: SPARC Enterprise T5120
cpu0 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu1 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu2 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu3 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu4 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu5 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu6 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu7 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu8 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu9 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu10 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu11 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu12 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu13 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu14 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu15 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
vbus0 at mainbus0
"flashprom" at vbus0 not configured
"tpm" at vbus0 not configured
cbus0 at vbus0
vldc0 at cbus0
vldcp0 at vldc0 chan 0x14: ivec 0x28, 0x29 channel "spds"
"sunvts" at vldc0 chan 0x6 not configured
"sunmc" at vldc0 chan 0x7 not configured
"explorer" at vldc0 chan 0x8 not configured
"led" at vldc0 chan 0x9 not configured
"flashupdate" at vldc0 chan 0xa not configured
"ipmi" at vldc0 chan 0xc not configured
"system-management" at vldc0 chan 0xd not configured
vldc1 at cbus0
"spfma" at vldc1 chan 0x5 not configured
vldc2 at cbus0
vldcp1 at vldc2 chan 0x0: ivec 0x0, 0x1 channel "hvctl"
"ldom-primary" at vldc2 chan 0x1 not configured
"fmactl" at vldc2 chan 0x3 not configured
vldcp2 at vldc2 chan 0x19: ivec 0x32, 0x33 channel "ldom-current"
vldcp3 at vldc2 chan 0x1d: ivec 0x3a, 0x3b channel "ldom-debian"
vldcp4 at vldc2 chan 0x22: ivec 0x44, 0x45 channel "ldom-gentoo"
vldc3 at cbus0
"ldmfma" at vldc3 chan 0x4 not configured
"virtual-domain-service" at cbus0 not configured
vcc0 at cbus0
vcctty0 at vcc0 chan 0x18: ivec 0x30, 0x31 domain "current"
vcctty1 at vcc0 chan 0x1c: ivec 0x38, 0x39 domain "debian"
vcctty2 at vcc0 chan 0x21: ivec 0x42, 0x43 domain "gentoo"
vds0 at cbus0
vdsp0 at vds0 chan 0x1a: ivec 0x34, 0x35
vdsp1 at vds0 chan 0x1e: ivec 0x3c, 0x3d
vdsp2 at vds0 chan 0x1f: ivec 0x3e, 0x3f
vdsp3 at vds0 chan 0x23: ivec 0x46, 0x47
vdsp4 at vds0 chan 0x24: ivec 0x48, 0x49
vsw0 at cbus0
vnet0 at vsw0 chan 0x1b: ivec 0x36, 0x37
vnet1 at vsw0 chan 0x20: ivec 0x40, 0x41
vnet2 at vsw0 chan 0x25: ivec 0x4a, 0x4b
vrng0 at vbus0
vcons0 at vbus0: ivec 0x111: console
vrtc0 at vbus0
vpci0 at mainbus0: bus 2 to 18, dvma map 80000000-ffffffff
pci0 at vpci0
ppb0 at pci0 dev 0 function 0 "PLX PEX 8533" rev 0xaa
pci1 at ppb0 bus 3
ppb1 at pci1 dev 1 function 0 "PLX PEX 8533" rev 0xaa
pci2 at ppb1 bus 4
ppb2 at pci2 dev 0 function 0 "PLX PEX 8517" rev 0xac
pci3 at ppb2 bus 5
ppb3 at pci3 dev 1 function 0 "PLX PEX 8517" rev 0xac
pci4 at ppb3 bus 6
ppb4 at pci4 dev 0 function 0 "PLX PEX 8112" rev 0xaa
pci5 at ppb4 bus 7
ohci0 at pci5 dev 0 function 0 "NEC USB" rev 0x43: ivec 0x16, version 1.0
ohci1 at pci5 dev 0 function 1 "NEC USB" rev 0x43: ivec 0x17, version 1.0
ehci0 at pci5 dev 0 function 2 "NEC USB" rev 0x04: ivec 0x14
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 configuration 1 interface 0 "NEC EHCI root hub" rev 2.00/1.00 addr 1
usb1 at ohci0: USB revision 1.0
uhub1 at usb1 configuration 1 interface 0 "NEC OHCI root hub" rev 1.00/1.00 addr 1
usb2 at ohci1: USB revision 1.0
uhub2 at usb2 configuration 1 interface 0 "NEC OHCI root hub" rev 1.00/1.00 addr 1
ppb5 at pci3 dev 2 function 0 "PLX PEX 8517" rev 0xac
pci6 at ppb5 bus 8
em0 at pci6 dev 0 function 0 "Intel 82571EB" rev 0x06: ivec 0x17, address 00:21:28:4f:cb:b4
em1 at pci6 dev 0 function 1 "Intel 82571EB" rev 0x06: ivec 0x14, address 00:21:28:4f:cb:b5
ppb6 at pci3 dev 3 function 0 "PLX PEX 8517" rev 0xaa
pci7 at ppb6 bus 9
em2 at pci7 dev 0 function 0 "Intel 82571EB" rev 0x06: ivec 0x14, address 00:21:28:4f:cb:b6
em3 at pci7 dev 0 function 1 "Intel 82571EB" rev 0x06: ivec 0x15, address 00:21:28:4f:cb:b7
ppb7 at pci1 dev 2 function 0 "PLX PEX 8533" rev 0xaa
pci8 at ppb7 bus 10
mpi0 at pci8 dev 0 function 0 "Symbios Logic SAS1068E" rev 0x04: ivec 0x16
mpi0: UNUSED, firmware 1.27.2.0
scsibus1 at mpi0: 112 targets
sd0 at scsibus1 targ 0 lun 0: <ATA, Samsung SSD 850, 2B6Q> naa.5002538d4076681a
sd0: 476940MB, 512 bytes/sector, 976773168 sectors
sd1 at scsibus1 targ 1 lun 0: <ATA, Samsung SSD 850, 2B6Q> naa.5002538d407bab2c
sd1: 476940MB, 512 bytes/sector, 976773168 sectors
ppb8 at pci1 dev 8 function 0 "PLX PEX 8533" rev 0xaa
pci9 at ppb8 bus 11
ppb9 at pci9 dev 0 function 0 "PLX PEX 8533" rev 0xaa
pci10 at ppb9 bus 12
ppb10 at pci10 dev 1 function 0 "PLX PEX 8533" rev 0xaa: ivec 0x16
pci11 at ppb10 bus 13
ppb11 at pci10 dev 2 function 0 "PLX PEX 8533" rev 0xaa: ivec 0x14
pci12 at ppb11 bus 14
ppb12 at pci10 dev 8 function 0 "PLX PEX 8533" rev 0xaa: ivec 0x14
pci13 at ppb12 bus 15
ppb13 at pci10 dev 9 function 0 "PLX PEX 8533" rev 0xaa: ivec 0x16
pci14 at ppb13 bus 16
ppb14 at pci10 dev 10 function 0 "PLX PEX 8533" rev 0xaa: ivec 0x14
pci15 at ppb14 bus 17
ppb15 at pci1 dev 9 function 0 "PLX PEX 8533" rev 0xaa: ivec 0x16
pci16 at ppb15 bus 18
"niu" at mainbus0 not configured
"pci-performance-counters" at mainbus0 not configured
ebus0 at mainbus0
com0 at ebus0 addr ca0000-ca0007 ivec 0x13: ns16550a, 16 byte fifo
umass0 at uhub0 port 2 configuration 1 interface 0 "Texas Instruments Incorporated 6250 FW: 04.02.02.22.562AD423" rev 2.00/2.00 addr 2
umass0: using SCSI over Bulk-Only
scsibus2 at umass0: 2 targets, initiator 0
cd0 at scsibus2 targ 1 lun 0: <TSSTcorp, CD/DVDW TS-T632A, SR03> removable serial.0451625fB05B31631B15
uhub3 at uhub0 port 4 configuration 1 interface 0 "Cypress Semiconductor USB2 Hub" rev 2.00/0.0b addr 3
vscsi0 at root
scsibus3 at vscsi0: 256 targets
softraid0 at root
scsibus4 at softraid0: 256 targets
sd2 at scsibus4 targ 1 lun 0: <OPENBSD, SR RAID 1, 006>
sd2: 476939MB, 512 bytes/sector, 976771712 sectors
bootpath: /pci@0,0/pci@0,0/pci@2,0/scsi@0,0/disk@0,0
root on sd2a (1244a9194ae0c119.a) swap on sd2b dump on sd2b
vnet2: watchdog timeout
vnet_sendmsg: ldc_send_unreliable: 35
vnet2: watchdog timeout
vnet2: watchdog timeout
vnet2: watchdog timeout
vnet2: watchdog timeout
vnet2: watchdog timeout
vnet2: watchdog timeout
vnet2: watchdog timeout
vnet2: watchdog timeout
vnet_sendmsg: ldc_send_unreliable: 35
vnet2: watchdog timeout
vnet_sendmsg: ldc_send_unreliable: 35
vnet2: watchdog timeout
vnet2: watchdog timeout
vnet2: watchdog timeout
vnet2: watchdog timeout
vnet2: watchdog timeout
	

2021

OpenBSD 6.9

dmesg
console is /virtual-devices@100/console@1
Copyright (c) 1982, 1986, 1989, 1991, 1993
	The Regents of the University of California.  All rights reserved.
Copyright (c) 1995-2021 OpenBSD. All rights reserved.  https://www.OpenBSD.org

OpenBSD 6.9 (GENERIC.MP) #794: Sun Apr 18 12:34:31 MDT 2021
    deraadt@sparc64.openbsd.org:/usr/src/sys/arch/sparc64/compile/GENERIC.MP
real mem = 17179869184 (16384MB)
avail mem = 16859045888 (16078MB)
random: good seed from bootblocks
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root: SPARC Enterprise T5120
cpu0 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu1 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu2 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu3 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu4 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu5 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu6 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu7 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu8 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu9 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu10 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu11 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu12 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu13 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu14 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu15 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
vbus0 at mainbus0
"flashprom" at vbus0 not configured
"tpm" at vbus0 not configured
cbus0 at vbus0
vldc0 at cbus0
vldcp0 at vldc0 chan 0x14: ivec 0x28, 0x29 channel "spds"
"sunvts" at vldc0 chan 0x6 not configured
"sunmc" at vldc0 chan 0x7 not configured
"explorer" at vldc0 chan 0x8 not configured
"led" at vldc0 chan 0x9 not configured
"flashupdate" at vldc0 chan 0xa not configured
"ipmi" at vldc0 chan 0xc not configured
"system-management" at vldc0 chan 0xd not configured
vldc1 at cbus0
"spfma" at vldc1 chan 0x5 not configured
vldc2 at cbus0
vldcp1 at vldc2 chan 0x0: ivec 0x0, 0x1 channel "hvctl"
"ldom-primary" at vldc2 chan 0x1 not configured
"fmactl" at vldc2 chan 0x3 not configured
vldcp2 at vldc2 chan 0x19: ivec 0x32, 0x33 channel "ldom-current"
vldcp3 at vldc2 chan 0x1d: ivec 0x3a, 0x3b channel "ldom-debian"
vldcp4 at vldc2 chan 0x22: ivec 0x44, 0x45 channel "ldom-gentoo"
vldc3 at cbus0
"ldmfma" at vldc3 chan 0x4 not configured
"virtual-domain-service" at cbus0 not configured
vcc0 at cbus0
vcctty0 at vcc0 chan 0x18: ivec 0x30, 0x31 domain "current"
vcctty1 at vcc0 chan 0x1c: ivec 0x38, 0x39 domain "debian"
vcctty2 at vcc0 chan 0x21: ivec 0x42, 0x43 domain "gentoo"
vds0 at cbus0
vdsp0 at vds0 chan 0x1a: ivec 0x34, 0x35
vdsp1 at vds0 chan 0x1e: ivec 0x3c, 0x3d
vdsp2 at vds0 chan 0x1f: ivec 0x3e, 0x3f
vdsp3 at vds0 chan 0x23: ivec 0x46, 0x47
vdsp4 at vds0 chan 0x24: ivec 0x48, 0x49
vsw0 at cbus0
vnet0 at vsw0 chan 0x1b: ivec 0x36, 0x37
vnet1 at vsw0 chan 0x20: ivec 0x40, 0x41
vnet2 at vsw0 chan 0x25: ivec 0x4a, 0x4b
vrng0 at vbus0
vcons0 at vbus0: ivec 0x111: console
vrtc0 at vbus0
vpci0 at mainbus0: bus 2 to 18, dvma map 80000000-ffffffff
pci0 at vpci0
ppb0 at pci0 dev 0 function 0 "PLX PEX 8533" rev 0xaa
pci1 at ppb0 bus 3
ppb1 at pci1 dev 1 function 0 "PLX PEX 8533" rev 0xaa
pci2 at ppb1 bus 4
ppb2 at pci2 dev 0 function 0 "PLX PEX 8517" rev 0xac
pci3 at ppb2 bus 5
ppb3 at pci3 dev 1 function 0 "PLX PEX 8517" rev 0xac
pci4 at ppb3 bus 6
ppb4 at pci4 dev 0 function 0 "PLX PEX 8112" rev 0xaa
pci5 at ppb4 bus 7
ohci0 at pci5 dev 0 function 0 "NEC USB" rev 0x43: ivec 0x16, version 1.0
ohci1 at pci5 dev 0 function 1 "NEC USB" rev 0x43: ivec 0x17, version 1.0
ehci0 at pci5 dev 0 function 2 "NEC USB" rev 0x04: ivec 0x14
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 configuration 1 interface 0 "NEC EHCI root hub" rev 2.00/1.00 addr 1
usb1 at ohci0: USB revision 1.0
uhub1 at usb1 configuration 1 interface 0 "NEC OHCI root hub" rev 1.00/1.00 addr 1
usb2 at ohci1: USB revision 1.0
uhub2 at usb2 configuration 1 interface 0 "NEC OHCI root hub" rev 1.00/1.00 addr 1
ppb5 at pci3 dev 2 function 0 "PLX PEX 8517" rev 0xac
pci6 at ppb5 bus 8
em0 at pci6 dev 0 function 0 "Intel 82571EB" rev 0x06: ivec 0x17, address 00:21:28:4f:cb:b4
em1 at pci6 dev 0 function 1 "Intel 82571EB" rev 0x06: ivec 0x14, address 00:21:28:4f:cb:b5
ppb6 at pci3 dev 3 function 0 "PLX PEX 8517" rev 0xaa
pci7 at ppb6 bus 9
em2 at pci7 dev 0 function 0 "Intel 82571EB" rev 0x06: ivec 0x14, address 00:21:28:4f:cb:b6
em3 at pci7 dev 0 function 1 "Intel 82571EB" rev 0x06: ivec 0x15, address 00:21:28:4f:cb:b7
ppb7 at pci1 dev 2 function 0 "PLX PEX 8533" rev 0xaa
pci8 at ppb7 bus 10
mpi0 at pci8 dev 0 function 0 "Symbios Logic SAS1068E" rev 0x04: ivec 0x16
mpi0: UNUSED, firmware 1.27.2.0
scsibus1 at mpi0: 112 targets
sd0 at scsibus1 targ 0 lun 0: <ATA, Samsung SSD 850, 2B6Q> naa.5002538d4076681a
sd0: 476940MB, 512 bytes/sector, 976773168 sectors
sd1 at scsibus1 targ 1 lun 0: <ATA, Samsung SSD 850, 2B6Q> naa.5002538d407bab2c
sd1: 476940MB, 512 bytes/sector, 976773168 sectors
ppb8 at pci1 dev 8 function 0 "PLX PEX 8533" rev 0xaa
pci9 at ppb8 bus 11
ppb9 at pci9 dev 0 function 0 "PLX PEX 8533" rev 0xaa
pci10 at ppb9 bus 12
ppb10 at pci10 dev 1 function 0 "PLX PEX 8533" rev 0xaa: ivec 0x16
pci11 at ppb10 bus 13
ppb11 at pci10 dev 2 function 0 "PLX PEX 8533" rev 0xaa: ivec 0x14
pci12 at ppb11 bus 14
ppb12 at pci10 dev 8 function 0 "PLX PEX 8533" rev 0xaa: ivec 0x14
pci13 at ppb12 bus 15
ppb13 at pci10 dev 9 function 0 "PLX PEX 8533" rev 0xaa: ivec 0x16
pci14 at ppb13 bus 16
ppb14 at pci10 dev 10 function 0 "PLX PEX 8533" rev 0xaa: ivec 0x14
pci15 at ppb14 bus 17
ppb15 at pci1 dev 9 function 0 "PLX PEX 8533" rev 0xaa: ivec 0x16
pci16 at ppb15 bus 18
"niu" at mainbus0 not configured
"pci-performance-counters" at mainbus0 not configured
ebus0 at mainbus0
com0 at ebus0 addr ca0000-ca0007 ivec 0x13: ns16550a, 16 byte fifo
umass0 at uhub0 port 2 configuration 1 interface 0 "Texas Instruments Incorporated 6250 FW: 04.02.02.22.562AD423" rev 2.00/2.00 addr 2
umass0: using SCSI over Bulk-Only
scsibus2 at umass0: 2 targets, initiator 0
cd0 at scsibus2 targ 1 lun 0: <TSSTcorp, CD/DVDW TS-T632A, SR03> removable serial.0451625fB05B31631B15
uhub3 at uhub0 port 4 configuration 1 interface 0 "Cypress Semiconductor USB2 Hub" rev 2.00/0.0b addr 3
vscsi0 at root
scsibus3 at vscsi0: 256 targets
softraid0 at root
scsibus4 at softraid0: 256 targets
softraid0: sd2 was not shutdown properly
sd2 at scsibus4 targ 1 lun 0: <OPENBSD, SR RAID 1, 006>
sd2: 476939MB, 512 bytes/sector, 976771712 sectors
bootpath: /pci@0,0/pci@0,0/pci@2,0/scsi@0,0/disk@0,0
root on sd2a (1244a9194ae0c119.a) swap on sd2b dump on sd2b
WARNING: / was not properly unmounted
VOP_OPEN: /home/vdsk/current.img, 2
VOP_OPEN: /home/vdsk/debian.img, 2
VOP_OPEN: /home/vdsk/gentoo.img, 2
	

Replace thermal paste

I finally decided to open it up, clean out the dust and replace the thermal paste. Everything inside looked good, but one of the heatsink mounting screws was loose.

Replace power supply

One of the power supplies had an intermittent fault, so I replaced that power supply with another one I had on hand.

OpenBSD 7.0

dmesg
console is /virtual-devices@100/console@1
Copyright (c) 1982, 1986, 1989, 1991, 1993
	The Regents of the University of California.  All rights reserved.
Copyright (c) 1995-2021 OpenBSD. All rights reserved.  https://www.OpenBSD.org

OpenBSD 7.0 (GENERIC.MP) #987: Thu Sep 30 17:22:47 MDT 2021
    deraadt@sparc64.openbsd.org:/usr/src/sys/arch/sparc64/compile/GENERIC.MP
real mem = 17179869184 (16384MB)
avail mem = 16859021312 (16078MB)
random: good seed from bootblocks
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root: SPARC Enterprise T5120
cpu0 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu1 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu2 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu3 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu4 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu5 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu6 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu7 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu8 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu9 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu10 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu11 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu12 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu13 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu14 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu15 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
vbus0 at mainbus0
"flashprom" at vbus0 not configured
"tpm" at vbus0 not configured
cbus0 at vbus0
vldc0 at cbus0
vldcp0 at vldc0 chan 0x14: ivec 0x28, 0x29 channel "spds"
"sunvts" at vldc0 chan 0x6 not configured
"sunmc" at vldc0 chan 0x7 not configured
"explorer" at vldc0 chan 0x8 not configured
"led" at vldc0 chan 0x9 not configured
"flashupdate" at vldc0 chan 0xa not configured
"ipmi" at vldc0 chan 0xc not configured
"system-management" at vldc0 chan 0xd not configured
vldc1 at cbus0
"spfma" at vldc1 chan 0x5 not configured
vldc2 at cbus0
vldcp1 at vldc2 chan 0x0: ivec 0x0, 0x1 channel "hvctl"
"ldom-primary" at vldc2 chan 0x1 not configured
"fmactl" at vldc2 chan 0x3 not configured
vldcp2 at vldc2 chan 0x19: ivec 0x32, 0x33 channel "ldom-current"
vldcp3 at vldc2 chan 0x1d: ivec 0x3a, 0x3b channel "ldom-debian"
vldcp4 at vldc2 chan 0x22: ivec 0x44, 0x45 channel "ldom-gentoo"
vldc3 at cbus0
"ldmfma" at vldc3 chan 0x4 not configured
"virtual-domain-service" at cbus0 not configured
vcc0 at cbus0
vcctty0 at vcc0 chan 0x18: ivec 0x30, 0x31 domain "current"
vcctty1 at vcc0 chan 0x1c: ivec 0x38, 0x39 domain "debian"
vcctty2 at vcc0 chan 0x21: ivec 0x42, 0x43 domain "gentoo"
vds0 at cbus0
vdsp0 at vds0 chan 0x1a: ivec 0x34, 0x35
vdsp1 at vds0 chan 0x1e: ivec 0x3c, 0x3d
vdsp2 at vds0 chan 0x1f: ivec 0x3e, 0x3f
vdsp3 at vds0 chan 0x23: ivec 0x46, 0x47
vdsp4 at vds0 chan 0x24: ivec 0x48, 0x49
vsw0 at cbus0
vnet0 at vsw0 chan 0x1b: ivec 0x36, 0x37
vnet1 at vsw0 chan 0x20: ivec 0x40, 0x41
vnet2 at vsw0 chan 0x25: ivec 0x4a, 0x4b
vrng0 at vbus0
vcons0 at vbus0: ivec 0x111: console
vrtc0 at vbus0
vpci0 at mainbus0: bus 2 to 18, dvma map 80000000-ffffffff
pci0 at vpci0
ppb0 at pci0 dev 0 function 0 "PLX PEX 8533" rev 0xaa
pci1 at ppb0 bus 3
ppb1 at pci1 dev 1 function 0 "PLX PEX 8533" rev 0xaa
pci2 at ppb1 bus 4
ppb2 at pci2 dev 0 function 0 "PLX PEX 8517" rev 0xac
pci3 at ppb2 bus 5
ppb3 at pci3 dev 1 function 0 "PLX PEX 8517" rev 0xac
pci4 at ppb3 bus 6
ppb4 at pci4 dev 0 function 0 "PLX PEX 8112" rev 0xaa
pci5 at ppb4 bus 7
ohci0 at pci5 dev 0 function 0 "NEC USB" rev 0x43: ivec 0x16, version 1.0
ohci1 at pci5 dev 0 function 1 "NEC USB" rev 0x43: ivec 0x17, version 1.0
ehci0 at pci5 dev 0 function 2 "NEC USB" rev 0x04: ivec 0x14
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 configuration 1 interface 0 "NEC EHCI root hub" rev 2.00/1.00 addr 1
usb1 at ohci0: USB revision 1.0
uhub1 at usb1 configuration 1 interface 0 "NEC OHCI root hub" rev 1.00/1.00 addr 1
usb2 at ohci1: USB revision 1.0
uhub2 at usb2 configuration 1 interface 0 "NEC OHCI root hub" rev 1.00/1.00 addr 1
ppb5 at pci3 dev 2 function 0 "PLX PEX 8517" rev 0xac
pci6 at ppb5 bus 8
em0 at pci6 dev 0 function 0 "Intel 82571EB" rev 0x06: ivec 0x17, address 00:21:28:4f:cb:b4
em1 at pci6 dev 0 function 1 "Intel 82571EB" rev 0x06: ivec 0x14, address 00:21:28:4f:cb:b5
ppb6 at pci3 dev 3 function 0 "PLX PEX 8517" rev 0xaa
pci7 at ppb6 bus 9
em2 at pci7 dev 0 function 0 "Intel 82571EB" rev 0x06: ivec 0x14, address 00:21:28:4f:cb:b6
em3 at pci7 dev 0 function 1 "Intel 82571EB" rev 0x06: ivec 0x15, address 00:21:28:4f:cb:b7
ppb7 at pci1 dev 2 function 0 "PLX PEX 8533" rev 0xaa
pci8 at ppb7 bus 10
mpi0 at pci8 dev 0 function 0 "Symbios Logic SAS1068E" rev 0x04: ivec 0x16
mpi0: UNUSED, firmware 1.27.2.0
scsibus1 at mpi0: 112 targets
sd0 at scsibus1 targ 0 lun 0: <ATA, Samsung SSD 850, 2B6Q> naa.5002538d4076681a
sd0: 476940MB, 512 bytes/sector, 976773168 sectors
sd1 at scsibus1 targ 1 lun 0: <ATA, Samsung SSD 850, 2B6Q> naa.5002538d407bab2c
sd1: 476940MB, 512 bytes/sector, 976773168 sectors
ppb8 at pci1 dev 8 function 0 "PLX PEX 8533" rev 0xaa
pci9 at ppb8 bus 11
ppb9 at pci9 dev 0 function 0 "PLX PEX 8533" rev 0xaa
pci10 at ppb9 bus 12
ppb10 at pci10 dev 1 function 0 "PLX PEX 8533" rev 0xaa: ivec 0x16
pci11 at ppb10 bus 13
ppb11 at pci10 dev 2 function 0 "PLX PEX 8533" rev 0xaa: ivec 0x14
pci12 at ppb11 bus 14
ppb12 at pci10 dev 8 function 0 "PLX PEX 8533" rev 0xaa: ivec 0x14
pci13 at ppb12 bus 15
ppb13 at pci10 dev 9 function 0 "PLX PEX 8533" rev 0xaa: ivec 0x16
pci14 at ppb13 bus 16
ppb14 at pci10 dev 10 function 0 "PLX PEX 8533" rev 0xaa: ivec 0x14
pci15 at ppb14 bus 17
ppb15 at pci1 dev 9 function 0 "PLX PEX 8533" rev 0xaa: ivec 0x16
pci16 at ppb15 bus 18
"niu" at mainbus0 not configured
"pci-performance-counters" at mainbus0 not configured
ebus0 at mainbus0
com0 at ebus0 addr ca0000-ca0007 ivec 0x13: ns16550a, 16 byte fifo
dt: 445 probes
umass0 at uhub0 port 2 configuration 1 interface 0 "Texas Instruments Incorporated 6250 FW: 04.02.02.22.562AD423" rev 2.00/2.00 addr 2
umass0: using SCSI over Bulk-Only
scsibus2 at umass0: 2 targets, initiator 0
cd0 at scsibus2 targ 1 lun 0: <TSSTcorp, CD/DVDW TS-T632A, SR03> removable serial.0451625fB05B31631B15
uhub3 at uhub0 port 4 configuration 1 interface 0 "Cypress Semiconductor USB2 Hub" rev 2.00/0.0b addr 3
vscsi0 at root
scsibus3 at vscsi0: 256 targets
softraid0 at root
scsibus4 at softraid0: 256 targets
sd2 at scsibus4 targ 1 lun 0: <OPENBSD, SR RAID 1, 006>
sd2: 476939MB, 512 bytes/sector, 976771712 sectors
bootpath: /pci@0,0/pci@0,0/pci@2,0/scsi@0,0/disk@0,0
root on sd2a (1244a9194ae0c119.a) swap on sd2b dump on sd2b
	

The upgrade Went smoothly modulo sysupgrade(1) not working correctly. I suspect because I changed /home to be /nfs.

2022

OpenBSD 7.1

dmesg
console is /virtual-devices@100/console@1
Copyright (c) 1982, 1986, 1989, 1991, 1993
	The Regents of the University of California.  All rights reserved.
Copyright (c) 1995-2022 OpenBSD. All rights reserved.  https://www.OpenBSD.org

OpenBSD 7.1 (GENERIC.MP) #1269: Mon Apr 11 22:05:10 MDT 2022
    deraadt@sparc64.openbsd.org:/usr/src/sys/arch/sparc64/compile/GENERIC.MP
real mem = 17179869184 (16384MB)
avail mem = 16859013120 (16078MB)
random: good seed from bootblocks
mpath0 at root
scsibus0 at mpath0: 256 targets
mainbus0 at root: SPARC Enterprise T5120
cpu0 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu1 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu2 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu3 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu4 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu5 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu6 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu7 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu8 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu9 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu10 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu11 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu12 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu13 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu14 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
cpu15 at mainbus0: SUNW,UltraSPARC-T2 (rev 0.0) @ 1415.103 MHz
vbus0 at mainbus0
"flashprom" at vbus0 not configured
"tpm" at vbus0 not configured
cbus0 at vbus0
vldc0 at cbus0
vldcp0 at vldc0 chan 0x14: ivec 0x28, 0x29 channel "spds"
"sunvts" at vldc0 chan 0x6 not configured
"sunmc" at vldc0 chan 0x7 not configured
"explorer" at vldc0 chan 0x8 not configured
"led" at vldc0 chan 0x9 not configured
"flashupdate" at vldc0 chan 0xa not configured
"ipmi" at vldc0 chan 0xc not configured
"system-management" at vldc0 chan 0xd not configured
vldc1 at cbus0
"spfma" at vldc1 chan 0x5 not configured
vldc2 at cbus0
vldcp1 at vldc2 chan 0x0: ivec 0x0, 0x1 channel "hvctl"
"ldom-primary" at vldc2 chan 0x1 not configured
"fmactl" at vldc2 chan 0x3 not configured
vldcp2 at vldc2 chan 0x19: ivec 0x32, 0x33 channel "ldom-current"
vldcp3 at vldc2 chan 0x1d: ivec 0x3a, 0x3b channel "ldom-debian"
vldcp4 at vldc2 chan 0x22: ivec 0x44, 0x45 channel "ldom-gentoo"
vldc3 at cbus0
"ldmfma" at vldc3 chan 0x4 not configured
"virtual-domain-service" at cbus0 not configured
vcc0 at cbus0
vcctty0 at vcc0 chan 0x18: ivec 0x30, 0x31 domain "current"
vcctty1 at vcc0 chan 0x1c: ivec 0x38, 0x39 domain "debian"
vcctty2 at vcc0 chan 0x21: ivec 0x42, 0x43 domain "gentoo"
vds0 at cbus0
vdsp0 at vds0 chan 0x1a: ivec 0x34, 0x35
vdsp1 at vds0 chan 0x1e: ivec 0x3c, 0x3d
vdsp2 at vds0 chan 0x1f: ivec 0x3e, 0x3f
vdsp3 at vds0 chan 0x23: ivec 0x46, 0x47
vdsp4 at vds0 chan 0x24: ivec 0x48, 0x49
vsw0 at cbus0
vnet0 at vsw0 chan 0x1b: ivec 0x36, 0x37
vnet1 at vsw0 chan 0x20: ivec 0x40, 0x41
vnet2 at vsw0 chan 0x25: ivec 0x4a, 0x4b
vrng0 at vbus0
vcons0 at vbus0: ivec 0x111: console
vrtc0 at vbus0
vpci0 at mainbus0: bus 2 to 18, dvma map 80000000-ffffffff
pci0 at vpci0
ppb0 at pci0 dev 0 function 0 "PLX PEX 8533" rev 0xaa
pci1 at ppb0 bus 3
ppb1 at pci1 dev 1 function 0 "PLX PEX 8533" rev 0xaa
pci2 at ppb1 bus 4
ppb2 at pci2 dev 0 function 0 "PLX PEX 8517" rev 0xac
pci3 at ppb2 bus 5
ppb3 at pci3 dev 1 function 0 "PLX PEX 8517" rev 0xac
pci4 at ppb3 bus 6
ppb4 at pci4 dev 0 function 0 "PLX PEX 8112" rev 0xaa
pci5 at ppb4 bus 7
ohci0 at pci5 dev 0 function 0 "NEC USB" rev 0x43: ivec 0x16, version 1.0
ohci1 at pci5 dev 0 function 1 "NEC USB" rev 0x43: ivec 0x17, version 1.0
ehci0 at pci5 dev 0 function 2 "NEC USB" rev 0x04: ivec 0x14
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 configuration 1 interface 0 "NEC EHCI root hub" rev 2.00/1.00 addr 1
usb1 at ohci0: USB revision 1.0
uhub1 at usb1 configuration 1 interface 0 "NEC OHCI root hub" rev 1.00/1.00 addr 1
usb2 at ohci1: USB revision 1.0
uhub2 at usb2 configuration 1 interface 0 "NEC OHCI root hub" rev 1.00/1.00 addr 1
ppb5 at pci3 dev 2 function 0 "PLX PEX 8517" rev 0xac
pci6 at ppb5 bus 8
em0 at pci6 dev 0 function 0 "Intel 82571EB" rev 0x06: ivec 0x17, address 00:21:28:4f:cb:b4
em1 at pci6 dev 0 function 1 "Intel 82571EB" rev 0x06: ivec 0x14, address 00:21:28:4f:cb:b5
ppb6 at pci3 dev 3 function 0 "PLX PEX 8517" rev 0xaa
pci7 at ppb6 bus 9
em2 at pci7 dev 0 function 0 "Intel 82571EB" rev 0x06: ivec 0x14, address 00:21:28:4f:cb:b6
em3 at pci7 dev 0 function 1 "Intel 82571EB" rev 0x06: ivec 0x15, address 00:21:28:4f:cb:b7
ppb7 at pci1 dev 2 function 0 "PLX PEX 8533" rev 0xaa
pci8 at ppb7 bus 10
mpi0 at pci8 dev 0 function 0 "Symbios Logic SAS1068E" rev 0x04: ivec 0x16
mpi0: UNUSED, firmware 1.27.2.0
scsibus1 at mpi0: 112 targets
sd0 at scsibus1 targ 0 lun 0: <ATA, Samsung SSD 850, 2B6Q> naa.5002538d4076681a
sd0: 476940MB, 512 bytes/sector, 976773168 sectors
sd1 at scsibus1 targ 1 lun 0: <ATA, Samsung SSD 850, 2B6Q> naa.5002538d407bab2c
sd1: 476940MB, 512 bytes/sector, 976773168 sectors
ppb8 at pci1 dev 8 function 0 "PLX PEX 8533" rev 0xaa
pci9 at ppb8 bus 11
ppb9 at pci9 dev 0 function 0 "PLX PEX 8533" rev 0xaa
pci10 at ppb9 bus 12
ppb10 at pci10 dev 1 function 0 "PLX PEX 8533" rev 0xaa: ivec 0x16
pci11 at ppb10 bus 13
ppb11 at pci10 dev 2 function 0 "PLX PEX 8533" rev 0xaa: ivec 0x14
pci12 at ppb11 bus 14
ppb12 at pci10 dev 8 function 0 "PLX PEX 8533" rev 0xaa: ivec 0x14
pci13 at ppb12 bus 15
ppb13 at pci10 dev 9 function 0 "PLX PEX 8533" rev 0xaa: ivec 0x16
pci14 at ppb13 bus 16
ppb14 at pci10 dev 10 function 0 "PLX PEX 8533" rev 0xaa: ivec 0x14
pci15 at ppb14 bus 17
ppb15 at pci1 dev 9 function 0 "PLX PEX 8533" rev 0xaa: ivec 0x16
pci16 at ppb15 bus 18
"niu" at mainbus0 not configured
"pci-performance-counters" at mainbus0 not configured
ebus0 at mainbus0
com0 at ebus0 addr ca0000-ca0007 ivec 0x13: ns16550a, 16 byte fifo
umass0 at uhub0 port 2 configuration 1 interface 0 "Texas Instruments Incorporated 6250 FW: 04.02.02.22.562AD423" rev 2.00/2.00 addr 2
umass0: using SCSI over Bulk-Only
scsibus2 at umass0: 2 targets, initiator 0
cd0 at scsibus2 targ 1 lun 0: <TSSTcorp, CD/DVDW TS-T632A, SR03> removable serial.0451625fB05B31631B15
uhub3 at uhub0 port 4 configuration 1 interface 0 "Cypress Semiconductor USB2 Hub" rev 2.00/0.0b addr 3
vscsi0 at root
scsibus3 at vscsi0: 256 targets
softraid0 at root
scsibus4 at softraid0: 256 targets
sd2 at scsibus4 targ 1 lun 0: <OPENBSD, SR RAID 1, 006>
sd2: 476939MB, 512 bytes/sector, 976771712 sectors
bootpath: /pci@0,0/pci@0,0/pci@2,0/scsi@0,0/disk@0,0
root on sd2a (1244a9194ae0c119.a) swap on sd2b dump on sd2b